===== Hezke Cisco clanky =====
http://www.samuraj-cz.com/clanek/cisco-ios-7-konfigurace-vlan-vtp/
**2960**
switch(config)#int f0/16
switch(config-if)#description Trunk_To_Linux_Router
switch(config-if)#switchport trunk allowed vlan 11,12
switch(config-if)#switchport mode trunk
switch(config-if)#no shutdown
switch(config-if)#exit
**3548-XL-EN** to same, ale bohuzel nekompatibilni konfigurace
cisco4(config)#interface FastEthernet0/48
cisco4(config-if)#switchport access vlan 100
cisco4(config-if)#switchport trunk allowed vlan 4,10,98,100
cisco4(config-if)#switchport mode trunk
cisco4(config-if)#switchport trunk encapsulation dot1q
cisco4(config-if)#spanning-tree portfast
cisco4(config-if)#exit
A moje mala pomucka pro 3548, ktera neumi //range//.
for i in `seq 43 48`; do
echo interface FastEthernet0/$i
echo switchport access vlan 100
echo switchport trunk allowed vlan 4,10,98,100
echo switchport mode trunk
echo switchport trunk encapsulation dot1q
echo spanning-tree portfast
echo exit
done
Also note that a 3548XL is a Layer 2 switch. This means that the only thing it needs an
IP address for is for management. Notice that even though you have (and have been
allowed to) configured IP addresses on interface VLAN 100/200, both those interfaces are in shutdown. Only one VLAN interface with an IP address can be active at any given time, and by default it is VLAN 1 on a Cat3548XL.